EXCEL - Formule pour tester la couleur d'une cellule

L'objectif est de créer une nouvelle fonction dans EXCEL, qui va nous ajouter un maximum de possibilité de traietement sur les couleurs.

Nous aurions pu tester si une cellule était verte par ex. Mais cela n'a pas de sens, et voici pourquoi :

Lorsqu'une cellule est colorée sur EXCEL, l'object cellule a une valeur interne contenant la valeur de la couleur.

On peu donc savoir immédiatement si une cellule a une couleur ou non (si couleur=0 alors pas de couleur).

Puis si l'on a accès a la table des codes couleur, grace a ce renvoie, on peut trouver la couleur.

Une fois ceci posé et compris, voici la démarche a suivre (cette fonction ne sera valide que dans le classeur ou elle a été déployée !) :

 

Entrer dans l'éditeur VBA en appuyant sur Alt-F11.
A gauche de l'écran, faire un clic-droit sur Module et choisir Insérer / Module.
Un double clic sur le module ainsi créé (qui s'appelle Module2, par exemple) et la fenêtre de code du module s'affiche.
Dans ce module, faire un copier-coller de ce qui suit,

' Code à copier-coller
Public Function COULEURCELLULE(Cible As Range) As Variant
COULEURCELLULE = Cible.Interior.ColorIndex
End Function

C'est tout. Bien penser a enregistrer !

 

Puis dans une cellule il suffit d'écrire :
=couleurcellule(A1)
pour afficher le numéro de la couleur de la cellule.
On peut aussi l'utiliser dans expression :
=SI(couleurcellule(A1)>0;"Cellule colorée";"Cellule sans couleur")

Les 56 couleurs d'Excel :

 

[Color 0] [Color 0]   [Color 15] [Color 15]   [Color 30] [Color 30]   [Color 45] [Color 45]
[Color 1] [Color 1]   [Color 16] [Color 16]   [Color 31] [Color 31]   [Color 46] [Color 46]
[Color 2] [Color 2]   [Color 17] [Color 17]   [Color 32] [Color 32]   [Color 47] [Color 47]
[Color 3] [Color 3]   [Color 18] [Color 18]   [Color 33] [Color 33]   [Color 48] [Color 48]
[Color 4] [Color 4]   [Color 19] [Color 19]   [Color 34] [Color 34]   [Color 49] [Color 49]
[Color 5] [Color 5]   [Color 20] [Color 20]   [Color 35] [Color 35]   [Color 50] [Color 50]
[Color 6] [Color 6]   [Color 21] [Color 21]   [Color 36] [Color 36]   [Color 51] [Color 51]
[Color 7] [Color 7]   [Color 22] [Color 22]   [Color 37] [Color 37]   [Color 52] [Color 52]
[Color 8] [Color 8]   [Color 23] [Color 23]   [Color 38] [Color 38]   [Color 53] [Color 53]
[Color 9] [Color 9]   [Color 24] [Color 24]   [Color 39] [Color 39]   [Color 54] [Color 54]
[Color 10] [Color 10]   [Color 25] [Color 25]   [Color 40] [Color 40]   [Color 55] [Color 55]
[Color 11] [Color 11]   [Color 26] [Color 26]   [Color 41] [Color 41]   [Color 56] [Color 56]
[Color 12] [Color 12]   [Color 27] [Color 27]   [Color 42] [Color 42]      
[Color 13] [Color 13]   [Color 28] [Color 28]   [Color 43] [Color 43]      
[Color 14] [Color 14]   [Color 29] [Color 29]   [Color 44] [Color 44]